Issue
A user is trying to publish emails using the Outlook add-in, but throughout the day this process is getting progressively slower/causing freezing.
Cause
This is caused by the users Deleted Items folder in Outlook having too many items. During the publishing progress, a copy of the email needs to be created in the Publish in Progress folder inside Outlook. This is then subsequently deleted and cleared from the deleted items to prevent a duplicate copy existing in Outlook.
When the add-in is scanning the deleted items folder to delete the copy, it is timing out. As you publish more throughout the day or carry out batch publish jobs, these deletion requests can stack up and cause larger timeouts.
Resolution
To prevent this from happening, the user needs to ensure that the deleted items folder in Outlook is regularly cleared out or archived.
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